The University of Texas at Austin
Hispanic Faculty Staff Association
Announcements:

Tues, Nov 12: General Meeting at Noon in GRE 3.120

  HFSA Home -> Distinctions -> Professional Development Award
PROFESSIONAL DEVELOPMENT AWARD
About the Award

HFSA shall award two professional development awards each year. $500 shall be awarded to the selected applicant in the staff category and $500 shall be awarded to the selected applicant in the faculty category.  The award must be used to pay for, or assist with, payment of a professional development opportunity (e.g. workshop, training, conference, etc.). In the event that there is no applicant in the faculty category, the selection committee may choose to select a 2nd recipient in the staff category.

Eligibility Criteria

Eligibility for recipients of the award shall be as follows:

  1. A current paid member of HFSA in good standing for at least two consecutive years (including the current year) prior to applying.
  2. Must have served as an HFSA committee chair or active committee member for at least two consecutive years (including the current year) prior to applying.
  3. May not reapply for at least 3 years after receiving a previous award.
  4. Shall not be a current HFSA officer.
  5. Shall provide a brief presentation to the HFSA membership, in the next academic year on how the funding was used.
  6. Shall return any unused funds and a copy of the receipt for activity for which the award was used.
Selection Methods

The executive board of HFSA shall appoint a minimum of three (3) people to serve on the Selection Committee.  The Selection Committee members shall not be related in any way or have a close personal relationship with any of the applicants of the award.

Submission Information

Completed applications should be sent NO LATER THAN 5:00pm on Friday, May 16, 2014.  Applications should be submitted to:


Steve Alvarez
Teresa Lozano Long Institute of Latin American Studies
SRH 1.301, Mail Code D0800
(512) 471-3090 (Fax)


To view documents in PDF format, you must have Adobe Reader® 8.0 or higher installed. Download it now.